about summary refs log tree commit diff
path: root/kittybox-rs/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-07-09 22:22:34 +0300
committerVika <vika@fireburn.ru>2023-07-17 01:53:42 +0300
commit99ff9cdc6890959cd4d2112c2e37b97ae83cb43c (patch)
tree31cdaf82de9d95ad4ee857f9148ad442f67db23d /kittybox-rs/Cargo.toml
parentdc7dfc61ec839175ebb51fcbaef1156fea5fdcf4 (diff)
cargo update, part 2: Axum
Axum got some breaking changes and gained some nice features —
however, features come later, breaking changes come first.

Perhaps it would be nice to actually construct a State with all of my
stuff, and then make functions generic over that. Could reduce the
amount of generic stuff I am producing... maybe.
Diffstat (limited to 'kittybox-rs/Cargo.toml')
-rw-r--r--kittybox-rs/Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/kittybox-rs/Cargo.toml b/kittybox-rs/Cargo.toml
index 1175828..71ebc66 100644
--- a/kittybox-rs/Cargo.toml
+++ b/kittybox-rs/Cargo.toml
@@ -114,10 +114,10 @@ features = ["io-util"]
 version = "^1.0.42"
 optional = true
 [dependencies.axum]
-version = "^0.5.11"
-features = ["multipart", "json", "headers", "form"]
+version = "^0.6.18"
+features = ["multipart", "json", "headers", "form", "macros"]
 [dependencies.axum-extra]
-version = "^0.3.7"
+version = "^0.7.4"
 features = ["cookie"]
 [dependencies.chrono]        # Date and time library for Rust
 version = "^0.4.19"