about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2025-01-01 06:32:41 +0300
committerVika <vika@fireburn.ru>2025-01-01 07:08:33 +0300
commit1a6f10aaaf79c4bb47f0359d82e719d1d5e52f2d (patch)
tree464161d3d11c89d651ffd1665c74afdb6d3e1ce8 /Cargo.toml
parentfc925564cc2324b1343da721b1e8aab680292ac9 (diff)
downloadkittybox-1a6f10aaaf79c4bb47f0359d82e719d1d5e52f2d.tar.zst
cargo update, bump msrv to match microformats crate
I need to actually verify the msrv tho

Change-Id: I61ce30845b9a076849ebc6adde65e58763b3741e
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 07211fe..6107033 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,7 +1,7 @@
 [package]
 name = "kittybox"
 version = "0.1.0"
-rust-version = "1.75.0"
+rust-version = "1.76.0"
 authors = ["Vika <vika@fireburn.ru>"]
 license = "AGPL-3.0-only"
 edition = "2021"
@@ -80,7 +80,7 @@ serde_json = "1.0.134"
 serde_urlencoded = "0.7.1"
 serde_variant = "0.1.3"
 sha2 = "0.10.8"
-sqlx = { version = "0.8.1", features = ["json"] }
+sqlx = { version = "0.8.2", features = ["json"] }
 thiserror = "2.0.9"
 time = "0.3.37"
 tokio = "1.42.0"
@@ -147,7 +147,7 @@ prometheus = { version = "0.13.4", features = ["process"] }
 rand = { workspace = true }
 redis = { version = "0.27.6", features = ["aio", "tokio-comp"], optional = true }
 relative-path = "1.9.3"
-reqwest = { version = "0.12.11", default-features = false, features = ["gzip", "brotli", "json", "stream"] }
+reqwest = { version = "0.12.12", default-features = false, features = ["gzip", "brotli", "json", "stream"] }
 reqwest-middleware = "0.4.0"
 serde = { workspace = true }
 serde_json = { workspace = true }