about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2025-01-01 05:57:47 +0300
committerVika <vika@fireburn.ru>2025-01-01 07:08:33 +0300
commitfc925564cc2324b1343da721b1e8aab680292ac9 (patch)
tree2619934c146f236ac377f91a44faccbe3abaa904 /Cargo.toml
parent5ad8443c8d6d9ed3f9d28ac52af529ceb41d741f (diff)
downloadkittybox-fc925564cc2324b1343da721b1e8aab680292ac9.tar.zst
Partially appease clippy
Some false positives on `serde(rename)` remain, as well as lints still
requiring my attention.

Change-Id: I3166771af20b2d07c6226b3b1a9d15fe36152356
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 467ad08..07211fe 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,6 +8,9 @@ edition = "2021"
 default-run = "kittybox"
 autobins = false
 
+[lints.rust]
+unexpected_cfgs = { level = "warn", check-cfg = ['cfg(tokio_unstable)'] }
+
 [features]
 default = ["rustls", "postgres"]
 webauthn = ["openssl", "dep:webauthn"]