about summary refs log tree commit diff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..3d0b4df
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,32 @@
+project('furtherance', 'rust',
+          version: '1.0.0',
+    meson_version: '>= 0.50.0',
+  default_options: [ 'warning_level=2',
+                   ],
+)
+
+# Dependencies
+dependency('sqlite3', version: '>= 3.20')
+dependency('dbus-1')
+
+dependency('glib-2.0', version: '>= 2.66')
+dependency('gio-2.0', version: '>= 2.66')
+dependency('gtk4', version: '>= 4.0.0')
+dependency('libadwaita-1', version: '>=1.0.0')
+
+name       = 'Furtherance'
+app_id     = 'com.lakoliu.Furtherance'
+
+i18n = import('i18n')
+
+
+cargo_sources = files(
+  'Cargo.toml',
+  'Cargo.lock',
+)
+
+subdir('data')
+subdir('src')
+subdir('po')
+
+meson.add_install_script('build-aux/meson/postinstall.py')