about summary refs log tree commit diff
path: root/meson.build
diff options
context:
space:
mode:
authorRicky Kresslein <ricky@kressle.in>2022-02-18 16:14:09 +0100
committerRicky Kresslein <ricky@kressle.in>2022-02-18 16:14:09 +0100
commitac99aca2510eebb83ac9a112849d8788ef67db3d (patch)
tree57bbddbf10a83f8abd5e5020b897ed80dc7d7e44 /meson.build
downloadFurtherance-ac99aca2510eebb83ac9a112849d8788ef67db3d.tar.zst
- Moved to com.lakoliu.Furtherance
- Removed development flag for release
- Created nicer about dialog
- Added description to data file
- Improved desktop file
- Changed database directory
- Delete All no longer enabled if no tasks
- Added GPL to top of every file
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..3d0b4df
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,32 @@
+project('furtherance', 'rust',
+          version: '1.0.0',
+    meson_version: '>= 0.50.0',
+  default_options: [ 'warning_level=2',
+                   ],
+)
+
+# Dependencies
+dependency('sqlite3', version: '>= 3.20')
+dependency('dbus-1')
+
+dependency('glib-2.0', version: '>= 2.66')
+dependency('gio-2.0', version: '>= 2.66')
+dependency('gtk4', version: '>= 4.0.0')
+dependency('libadwaita-1', version: '>=1.0.0')
+
+name       = 'Furtherance'
+app_id     = 'com.lakoliu.Furtherance'
+
+i18n = import('i18n')
+
+
+cargo_sources = files(
+  'Cargo.toml',
+  'Cargo.lock',
+)
+
+subdir('data')
+subdir('src')
+subdir('po')
+
+meson.add_install_script('build-aux/meson/postinstall.py')