summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index a5650c9..81d4916 100644
--- a/default.nix
+++ b/default.nix
@@ -19,6 +19,15 @@ let
 in crane.buildPackage (args' // {
   postInstall = ''
     install -Dm755 ${./xdg-desktop-portal-systemd.portal} $out/share/xdg-desktop-portal/portals/xdg-desktop-portal-systemd.portal
+
+    mkdir -p $out/share/systemd/user/
+    substituteAll ${./xdg-desktop-portal-systemd.service} $out/share/systemd/user/xdg-desktop-portal-systemd.service
+
+    mkdir -p $out/share/dbus-1/services/
+    substituteAll ${./xyz.vikanezrimaya.fdo.portal.Systemd.service} $out/share/dbus-1/services/xyz.vikanezrimaya.fdo.portal.Systemd.service
+
+    mkdir -p $out/share/applications
+    substituteAll ${./xdg-desktop-portal-systemd.desktop} $out/share/applications/xdg-desktop-portal-systemd.desktop
   '';
   passthru = {
     clippy = crane.cargoClippy (args' // {