summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-12-03 07:35:17 +0300
committerVika <vika@fireburn.ru>2024-12-03 07:36:15 +0300
commit0db801b049e752f4c78af0cf5ee5f728b5b1dced (patch)
tree53396cbd52160835f9d3d071d0201d23db76f5e1 /Cargo.toml
downloadxdg-desktop-portal-systemd-main.tar.zst
Initial commit HEAD main
Supposed to work, I guess. At least the idle inhibition part, which is
the part I care about.

State tracking is broken due to zbus weirdness. I have no desire to
debug this any further.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..48f0363
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "xdg-desktop-portal-systemd"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+futures-util = "0.3.31"
+serde = { version = "1.0.215", features = ["derive"] }
+tokio = { version = "1.41.1", features = ["full"] }
+zbus = { version = "5.1.1", default-features = false, features = ["tokio"] }
+zvariant = "5.1.0"