about summary refs log tree commit diff
path: root/util/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'util/Cargo.toml')
-rw-r--r--util/Cargo.toml18
1 files changed, 13 insertions, 5 deletions
diff --git a/util/Cargo.toml b/util/Cargo.toml
index 3d8327c..9a6558b 100644
--- a/util/Cargo.toml
+++ b/util/Cargo.toml
@@ -1,21 +1,23 @@
 [package]
 name = "kittybox-util"
-version = "0.1.0"
+version = "0.2.0"
 edition = "2021"
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [features]
-fs = ["rand", "tokio", "tokio/fs"]
+fs = ["dep:rand", "dep:tokio", "tokio/fs"]
+sqlx = ["dep:sqlx"]
+axum = ["dep:axum-core", "http"]
+http = ["dep:http"]
 
 [dependencies]
 serde = { version = "^1.0.170", features = ["derive"] }
 serde_json = "^1.0.64"
-axum-core = "^0.4.3"
-http = "^1.0"
 async-trait = "^0.1.50"
 futures-util = "^0.3.14"
 uuid = "^1.3.3"
+url = "2.5.2"
 [dependencies.rand]
 version = "^0.8.5"
 optional = true
@@ -26,4 +28,10 @@ optional = true
 [dependencies.sqlx]
 version = "0.8"
 features = ["json"]
-optional = true
\ No newline at end of file
+optional = true
+[dependencies.axum-core]
+version = "^0.4.3"
+optional = true
+[dependencies.http]
+version = "^1.0"
+optional = true