about summary refs log tree commit diff
path: root/util/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-08-20 00:35:30 +0300
committerVika <vika@fireburn.ru>2024-08-20 01:46:13 +0300
commitd6a8525274ccd96a5ce9540ea2ba1e463c84ff90 (patch)
tree9daa6fceda3f019629f99acb1b150882a5e151d4 /util/Cargo.toml
parenta46e16258f83cc5939c568bba3a62ccc28114365 (diff)
kittybox-util: 0.1.0 -> 0.2.0
Micropub types are now more coherent and gathered in one place.
Diffstat (limited to 'util/Cargo.toml')
-rw-r--r--util/Cargo.toml18
1 files changed, 13 insertions, 5 deletions
diff --git a/util/Cargo.toml b/util/Cargo.toml
index 3d8327c..9a6558b 100644
--- a/util/Cargo.toml
+++ b/util/Cargo.toml
@@ -1,21 +1,23 @@
 [package]
 name = "kittybox-util"
-version = "0.1.0"
+version = "0.2.0"
 edition = "2021"
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [features]
-fs = ["rand", "tokio", "tokio/fs"]
+fs = ["dep:rand", "dep:tokio", "tokio/fs"]
+sqlx = ["dep:sqlx"]
+axum = ["dep:axum-core", "http"]
+http = ["dep:http"]
 
 [dependencies]
 serde = { version = "^1.0.170", features = ["derive"] }
 serde_json = "^1.0.64"
-axum-core = "^0.4.3"
-http = "^1.0"
 async-trait = "^0.1.50"
 futures-util = "^0.3.14"
 uuid = "^1.3.3"
+url = "2.5.2"
 [dependencies.rand]
 version = "^0.8.5"
 optional = true
@@ -26,4 +28,10 @@ optional = true
 [dependencies.sqlx]
 version = "0.8"
 features = ["json"]
-optional = true
\ No newline at end of file
+optional = true
+[dependencies.axum-core]
+version = "^0.4.3"
+optional = true
+[dependencies.http]
+version = "^1.0"
+optional = true