about summary refs log tree commit diff
path: root/templates/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'templates/Cargo.toml')
-rw-r--r--templates/Cargo.toml32
1 files changed, 14 insertions, 18 deletions
diff --git a/templates/Cargo.toml b/templates/Cargo.toml
index b85a254..19855e6 100644
--- a/templates/Cargo.toml
+++ b/templates/Cargo.toml
@@ -6,28 +6,24 @@ edition = "2021"
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [build-dependencies]
-libflate = "^2.1.0"
-walkdir = "^2.5.0"
+libflate = { workspace = true }
+walkdir = { workspace = true }
 
 [dev-dependencies]
-faker_rand = "^0.1.1"
-rand = "^0.8.5"
-[dev-dependencies.time]
-version = "^0.3.37"
-features = ["parsing", "formatting"]
-[dev-dependencies.microformats]
-version="0.14.0"
+faker_rand = { workspace = true }
+rand = { workspace = true }
+time = { workspace = true, features = ["parsing", "formatting"] }
+microformats = { workspace = true }
 
 [dependencies]
-ellipse = "^0.2.0"
-http = "^1.2"
-markup = "^0.15.0"
-serde_json = "^1.0.134"
-include_dir = "^0.7.4"
-axum = "^0.7.9"
-[dependencies.chrono]
-version = "^0.4.39"
-features = ["serde"]
+axum = { workspace = true }
+chrono = { workspace = true }
+ellipse = { workspace = true }
+http = { workspace = true }
+include_dir = { workspace = true }
+markup = { workspace = true }
+serde_json = { workspace = true }
+
 [dependencies.kittybox-util]
 version = "0.3.0"
 path = "../util"