about summary refs log tree commit diff
path: root/templates/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'templates/Cargo.toml')
-rw-r--r--templates/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/templates/Cargo.toml b/templates/Cargo.toml
new file mode 100644
index 0000000..c4c7f46
--- /dev/null
+++ b/templates/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "kittybox-templates"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+ellipse = "^0.2.0"           # Truncate and ellipsize strings in a human-friendly way
+http = "^0.2.7"              # Hyper's strong HTTP types
+log = "^0.4.14"              # A lightweight logging facade for Rust
+markup = "^0.12.0"           # HTML templating engine
+serde_json = "^1.0.64"       # A JSON serialization file format
+[dependencies.chrono]        # Date and time library for Rust
+version = "^0.4.19"
+features = ["serde"]
+[dependencies.kittybox-util]
+version = "0.1.0"
+path = "../util"
\ No newline at end of file