about summary refs log tree commit diff
path: root/templates-neo/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'templates-neo/Cargo.toml')
-rw-r--r--templates-neo/Cargo.toml39
1 files changed, 16 insertions, 23 deletions
diff --git a/templates-neo/Cargo.toml b/templates-neo/Cargo.toml
index a6c3b8a..0be4dd2 100644
--- a/templates-neo/Cargo.toml
+++ b/templates-neo/Cargo.toml
@@ -6,36 +6,29 @@ edition = "2021"
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [build-dependencies]
-libflate = "^2.1.0"
-walkdir = "^2.5.0"
+libflate = { workspace = true }
+walkdir = { workspace = true }
 
 [dev-dependencies]
-faker_rand = "^0.1.1"
-rand = "^0.8.5"
+faker_rand = { workspace = true }
+rand = { workspace = true }
 
 [dependencies]
-ellipse = "^0.2.0"
-http = "^1.2"
-html = "^0.6.3"
-serde_json = "^1.0.134"
-include_dir = "^0.7.4"
-axum = "^0.7.9"
-thiserror = "2.0.9"
-[dependencies.url]
-# URL library for Rust, based on the WHATWG URL Standard
-version = "^2.5.4"
-features = ["serde"]
-[dependencies.time]
-version = "^0.3.37"
-features = ["formatting"]
-[dependencies.chrono]
-version = "^0.4.39"
-features = ["serde"]
+axum = { workspace = true }
+chrono = { workspace = true }
+ellipse = { workspace = true }
+html = { workspace = true }
+http = { workspace = true }
+include_dir = { workspace = true }
+microformats = { workspace = true }
+serde_json = { workspace = true }
+thiserror = { workspace = true }
+time = { workspace = true, features = ["formatting"] }
+url = { workspace = true }
+
 [dependencies.kittybox-util]
 version = "0.3.0"
 path = "../util"
 [dependencies.kittybox-indieauth]
 version = "0.2.0"
 path = "../indieauth"
-[dependencies.microformats]
-version="0.14.0"