about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index bf099b0..ce3991f 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,7 +3,7 @@
 , cargo-crev, cargo-audit
 , xh, systemfd, tokio-console, sqlx-cli
 , pkg-config, protobuf, openssl
-, typescript, typescript-language-server, caddy
+, nodePackages, caddy
 }:
 mkShell {
   name = "rust-dev-shell";
@@ -13,9 +13,10 @@ mkShell {
     cargo-watch cargo-edit cargo-outdated
     cargo-crev cargo-audit sqlx-cli
     xh systemfd caddy
-    typescript typescript-language-server
     # protobuf is required for tokio-console's console-subscriber
     #tokio-console protobuf
     pkg-config openssl
-  ];
+  ] ++ (with nodePackages; [
+    typescript typescript-language-server
+  ]);
 }