about summary refs log tree commit diff
path: root/kittybox.nix
diff options
context:
space:
mode:
Diffstat (limited to 'kittybox.nix')
-rw-r--r--kittybox.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/kittybox.nix b/kittybox.nix
index 1d66fc7..eea7006 100644
--- a/kittybox.nix
+++ b/kittybox.nix
@@ -1,7 +1,7 @@
 { stdenv, lib, naersk, lld, mold, typescript
 , useWebAuthn ? false, openssl, zlib, pkg-config, protobuf
 , usePostgres ? true, postgresql, postgresqlTestHook
-, nixosTests }:
+, nixosTest }:
 
 assert useWebAuthn -> openssl != null && pkg-config != null;
 assert usePostgres -> postgresql != null && postgresqlTestHook != null;
@@ -36,7 +36,14 @@ naersk.buildPackage rec {
   '';
 
   passthru = {
-    tests = nixosTests;
+    tests = {
+      distributed = nixosTest ./nixos-tests/distributed-test.nix;
+      smokeTest = nixosTest ./nixos-tests/smoke-test.nix;
+    } // (lib.optionalAttrs usePostgres {
+      webmention = nixosTest ./nixos-tests/webmention-test.nix;
+      postgresSmokeTest = nixosTest ./nixos-tests/postgres-smoke-test.nix;
+    });
+
     hasPostgres = usePostgres;
   };