about summary refs log tree commit diff
path: root/kittybox.nix
diff options
context:
space:
mode:
Diffstat (limited to 'kittybox.nix')
-rw-r--r--kittybox.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/kittybox.nix b/kittybox.nix
index eea7006..a8cac0e 100644
--- a/kittybox.nix
+++ b/kittybox.nix
@@ -29,6 +29,10 @@ naersk.buildPackage rec {
     postgresql postgresqlTestHook
   ];
 
+  # Cross-compilation support
+  CARGO_BUILD_TARGET = stdenv.targetPlatform.rust.cargoShortTarget;
+  "CARGO_TARGET_${stdenv.targetPlatform.rust.cargoEnvVarTarget}_RUSTFLAGS" = "-C linker=${stdenv.cc}/bin/${stdenv.cc.targetPrefix}cc";
+
   # Tests create arbitrary databases; we need to be prepared for that
   postgresqlTestUserOptions = "LOGIN SUPERUSER";
   postgresqlTestSetupPost = ''