about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 3 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9d4ba86..20d0f89 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -59,8 +59,8 @@ members = [".", "./util", "./templates", "./indieauth", "./templates-neo", "./to
 default-members = [".", "./util", "./templates", "./indieauth"]
 
 [workspace.dependencies]
-axum = "0.7.9"
-axum-core = "0.4.5"
+axum = "0.8.1"
+axum-core = "0.5.0"
 chrono = { version = "0.4.39", features = ["serde"] }
 clap = "4.5.23"
 data-encoding = "2.6.0"
@@ -124,9 +124,8 @@ wiremock = "0.6.2"
 [dependencies]
 anyhow = { version = "1.0.95", optional = true }
 argon2 = { version = "0.5.3", features = ["std"] }
-async-trait = "0.1.83"
 axum = { workspace = true, features = ["multipart", "json", "form", "macros"] }
-axum-extra = { version = "0.9.6", features = ["cookie", "cookie-signed", "typed-header"] }
+axum-extra = { version = "0.10.0", features = ["cookie", "cookie-signed", "typed-header"] }
 bytes = "1.9.0"
 chrono = { workspace = true }
 clap = { workspace = true, features = ["derive"], optional = true }