about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 2 insertions, 18 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8556c3b..73ee6ed 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,9 +19,6 @@ path = "src/bin/pyindieblog_to_kittybox.rs"
 required-features = ["util"]
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
-[patch.crates-io]
-mobc = { git = 'https://github.com/kisik21/mobc' }
-
 [dev-dependencies]
 tide-testing = "^0.1.3"      # tide testing helper
 mockito = "^0.30.0"          # HTTP mocking for Rust.
@@ -39,48 +36,35 @@ lazy_static = "^1.4.0"       # A macro for declaring lazily evaluated statics in
 log = "^0.4.14"              # A lightweight logging facade for Rust
 markdown = "^0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
 markup = "^0.12.0"           # HTML templating engine... ok also very funny about markdown and markup... i just realized the pun...
+mobc = "^0.7.2"              # A generic connection pool with async/await support
 newbase60 = "^0.1.3"         # A library that implements Tantek Çelik's New Base 60
 retainer = "^0.2.2"          # Minimal async cache in Rust with support for key expirations
 serde_json = "^1.0.64"       # A JSON serialization file format
 serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
 tide = "^0.16.0"             # A minimal and pragmatic Rust web application framework built for rapid development
-
 [dependencies.anyhow]
 version = "^1.0.42"
 optional = true
-
 [dependencies.async-std]     # Async version of the Rust standard library
 version = "^1.9.0"
 features = ["attributes"]
-
 [dependencies.chrono]        # Date and time library for Rust
 version = "^0.4.19"
 features = ["serde"]
-
-[dependencies.mobc]          # A generic connection pool with async/await support
-version = "^0.7.2"
-default-features = false
-features = ["async-std", "unstable"]
-
 [dependencies.mobc-redis]    # Redis support for the mobc connection pool
 version = "^0.7.0"
-default-features = false
 features = ["async-std-comp"]
-
+default-features = false
 [dependencies.prometheus]    # Prometheus instrumentation library for Rust applications
 version = "^0.12.0"
 features = ["process"]
-
 [dependencies.serde]         # A generic serialization/deserialization framework
 version = "^1.0.125"
 features = ["derive"]
-
 [dependencies.surf]          # Surf the web - HTTP client framework
 version = "^2.2.0"
 default-features = false
 features = ["h1-client-rustls", "encoding", "middleware-logger"]
-
 [dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
 version = "^2.2.1"
 features = ["serde"]
-