about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 9 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 15e0503..f072a0b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -80,7 +80,6 @@ argon2 = { version = "^0.5.3", features = ["std"] }
 async-trait = "^0.1.83"      # Type erasure for async trait methods
 bytes = "^1.9.0"
 data-encoding = "^2.6.0"     # Efficient and customizable data-encoding functions like base64, base32, and hex
-easy-scraper = "^0.2.0"      # HTML scraping library focused on ease of use
 either = "^1.13.0"            # A general purpose sum type with two cases
 futures = "^0.3.31"          # An implementation of futures and streams
 futures-util = "^0.3.31"     # Common utilities and extension traits for the futures-rs library
@@ -100,14 +99,14 @@ tracing = { version = "0.1.41", features = [] }
 tracing-tree = "0.4.0"
 tracing-log = "0.2.0"
 tracing-subscriber = { version = "0.3.19", features = ["env-filter", "json"] }
-tower-http = { version = "0.5.2", features = ["trace", "cors", "catch-panic", "sensitive-headers"] }
-tower = { version = "0.4.13", features = ["tracing"] }
+tower-http = { version = "0.6.2", features = ["trace", "cors", "catch-panic", "sensitive-headers"] }
+tower = { version = "0.5.2", features = ["tracing"] }
 webauthn = { version = "0.5.0", package = "webauthn-rs", features = ["danger-allow-state-serialisation"], optional = true }
 base64 = "0.22.1"
-html5ever = "0.27.0"
+html5ever = "=0.27.0"
 mime = "0.3.17"
-http-cache-reqwest = { version = "0.14.0", default-features = false, features = ["manager-moka"] }
-reqwest-middleware = "0.3.3"
+http-cache-reqwest = { version = "0.15.0", default-features = false, features = ["manager-moka"] }
+reqwest-middleware = "0.4.0"
 [dependencies.tokio]
 version = "^1.42.0"
 features = ["full", "tracing"] # TODO determine if my app doesn't need some features
@@ -132,7 +131,7 @@ features = ["cookie", "cookie-signed", "typed-header"]
 version = "^0.4.39"
 features = ["serde"]
 [dependencies.redis]
-version = "^0.26.1"
+version = "^0.27.6"
 optional = true
 features = ["aio", "tokio-comp"]
 [dependencies.prometheus]    # Prometheus instrumentation library for Rust applications
@@ -160,12 +159,12 @@ version = "4.5.23"
 features = ["derive"]
 optional = true
 [dependencies.thiserror]
-version = "1.0.69"
+version = "2.0.9"
 [dependencies.sqlx]
-version = "^0.8"
+version = "^0.8.1"
 features = ["uuid", "chrono", "json", "postgres", "runtime-tokio"]
 optional = true
 [dependencies.sqlparser]
-version = "0.44.0"
+version = "0.53.0"
 features = ["serde", "serde_json"]
 optional = true