about summary refs log tree commit diff
path: root/util/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-05-07 20:28:43 +0300
committerVika <vika@fireburn.ru>2022-05-07 20:28:43 +0300
commit139b7ec10bc7f08dae9bd57eef8eff73fbb22061 (patch)
tree973c4d903e731cb5e38b682f22c38c3da1dbcd92 /util/Cargo.toml
parent0679de841840c74ab49f54905783fac1faf028e1 (diff)
Split into different crates
Templates and utility types are now separate crates to speed up
compilation, linting and potential reuse/replacement.

Potentially more crates could be split out/modularized, resulting in
speedups, smaller binaries (whenever features are excluded) and even
more reuse capabilities.
Diffstat (limited to 'util/Cargo.toml')
-rw-r--r--util/Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/util/Cargo.toml b/util/Cargo.toml
new file mode 100644
index 0000000..31c6bca
--- /dev/null
+++ b/util/Cargo.toml
@@ -0,0 +1,12 @@
+[package]
+name = "kittybox-util"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+[dependencies.serde]         # A generic serialization/deserialization framework
+version = "^1.0.125"
+features = ["derive"]
+