about summary refs log tree commit diff
path: root/util/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-07-29 21:59:56 +0300
committerVika <vika@fireburn.ru>2023-07-29 21:59:56 +0300
commit0617663b249f9ca488e5de652108b17d67fbaf45 (patch)
tree11564b6c8fa37bf9203a0a4cc1c4e9cc088cb1a5 /util/Cargo.toml
parent26c2b79f6a6380ae3224e9309b9f3352f5717bd7 (diff)
Moved the entire Kittybox tree into the root
Diffstat (limited to 'util/Cargo.toml')
-rw-r--r--util/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/util/Cargo.toml b/util/Cargo.toml
new file mode 100644
index 0000000..0425849
--- /dev/null
+++ b/util/Cargo.toml
@@ -0,0 +1,29 @@
+[package]
+name = "kittybox-util"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[features]
+fs = ["rand", "tokio", "tokio/fs"]
+
+[dependencies]
+serde = { version = "^1.0.170", features = ["derive"] }
+serde_json = "^1.0.64"
+axum-core = "^0.3.4"
+http = "^0.2.7"
+async-trait = "^0.1.50"
+futures-util = "^0.3.14"
+uuid = "^1.3.3"
+[dependencies.rand]
+version = "^0.8.5"
+optional = true
+[dependencies.tokio]
+version = "^1.16.1"
+features = ["tracing"]
+optional = true
+[dependencies.sqlx]
+version = "0.7"
+features = ["json"]
+optional = true
\ No newline at end of file