about summary refs log tree commit diff
path: root/templates/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-05-24 17:18:30 +0300
committerVika <vika@fireburn.ru>2022-05-24 17:18:30 +0300
commit5610a5f0bf1a9df02bd3d5b55e2cdebef2440360 (patch)
tree8394bcf1dcc204043d7adeb8dde2e2746977606e /templates/Cargo.toml
parent2f93873122b47e42f7ee1c38f1f04d052a63599c (diff)
flake.nix: reorganize
 - Kittybox's source code is moved to a subfolder
   - This improves build caching by Nix since it doesn't take changes
     to other files into account
 - Package and test definitions were spun into separate files
   - This makes my flake.nix much easier to navigate
   - This also makes it somewhat possible to use without flakes (but
     it is still not easy, so use flakes!)
 - Some attributes were moved in compliance with Nix 2.8's changes to
   flake schema
Diffstat (limited to 'templates/Cargo.toml')
-rw-r--r--templates/Cargo.toml26
1 files changed, 0 insertions, 26 deletions
diff --git a/templates/Cargo.toml b/templates/Cargo.toml
deleted file mode 100644
index fe8ac19..0000000
--- a/templates/Cargo.toml
+++ /dev/null
@@ -1,26 +0,0 @@
-[package]
-name = "kittybox-templates"
-version = "0.1.0"
-edition = "2021"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dev-dependencies]
-faker_rand = "^0.1.1"
-rand = "^0.8.5"
-test-logger = "^0.1.0"
-[dev-dependencies.microformats]
-version="^0.2.0"
-
-[dependencies]
-ellipse = "^0.2.0"           # Truncate and ellipsize strings in a human-friendly way
-http = "^0.2.7"              # Hyper's strong HTTP types
-log = "^0.4.14"              # A lightweight logging facade for Rust
-markup = "^0.12.0"           # HTML templating engine
-serde_json = "^1.0.64"       # A JSON serialization file format
-[dependencies.chrono]        # Date and time library for Rust
-version = "^0.4.19"
-features = ["serde"]
-[dependencies.kittybox-util]
-version = "0.1.0"
-path = "../util"
\ No newline at end of file