about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-02-27 00:09:48 +0300
committerVika <vika@fireburn.ru>2023-02-27 00:09:48 +0300
commitd056148928b5c0ca4cdcb663fca7e143e97a3a41 (patch)
tree7dd2d05a7ac797ca57988dacabb57fed92480c1f /shell.nix
parenteb58228abf97ebca4ebe18d7803cbc2ca4c5df40 (diff)
Flake stuff
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/shell.nix b/shell.nix
index 75fd790..91b2c54 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,15 +1,18 @@
 { mkShell, rustc, cargo, rust-analyzer, clippy, rustfmt
-, cargo-watch, cargo-edit, cargo-outdated, cargo-crev
+, cargo-watch, cargo-edit, cargo-outdated
+, cargo-crev, cargo-audit
 , xh, systemfd, tokio-console
-, pkg-config, protobuf, typescript
+, pkg-config, protobuf, typescript, typescript-language-server
 }:
 mkShell {
   name = "rust-dev-shell";
 
   nativeBuildInputs = [
     rustc cargo rust-analyzer clippy rustfmt
-    cargo-watch cargo-edit cargo-outdated cargo-crev
-    xh systemfd typescript #tokio-console
+    cargo-watch cargo-edit cargo-outdated
+    cargo-crev cargo-audit
+    xh systemfd typescript typescript-language-server
+    #tokio-console
     # required for tokio-console's console-subscriber
     #pkg-config protobuf
   ];