about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-08-17 16:05:59 +0300
committerVika <vika@fireburn.ru>2024-08-17 16:05:59 +0300
commitc22267baea9facff8a3b25eeb3badcc16ac262e3 (patch)
tree8af177e64f178d29478a96d722816f767c1fe29b /shell.nix
parentf185df030530ae52fcb60b4cc958ca98da8cfaa1 (diff)
Add caddy to the dev shell
`caddy reverse-proxy -r --from https://localhost:8443 --to http://localhost:8080`
can help meet Kittybox's security assumptions in development (and
could be a good way to meet them in production too.)
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 5438e35..bf099b0 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,7 +3,7 @@
 , cargo-crev, cargo-audit
 , xh, systemfd, tokio-console, sqlx-cli
 , pkg-config, protobuf, openssl
-, typescript, typescript-language-server
+, typescript, typescript-language-server, caddy
 }:
 mkShell {
   name = "rust-dev-shell";
@@ -12,7 +12,8 @@ mkShell {
     rustc cargo rust-analyzer clippy rustfmt
     cargo-watch cargo-edit cargo-outdated
     cargo-crev cargo-audit sqlx-cli
-    xh systemfd typescript typescript-language-server
+    xh systemfd caddy
+    typescript typescript-language-server
     # protobuf is required for tokio-console's console-subscriber
     #tokio-console protobuf
     pkg-config openssl