about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-12-31 00:06:34 +0300
committerVika <vika@fireburn.ru>2024-12-31 00:06:34 +0300
commita18eb65b31676a7ee2a952437cc302265e5868da (patch)
tree1d408eb2cef88f9b50d636fd33030a3e1ed71faf /shell.nix
parent6300ccff4bb7f9e2e8167003fae51bec2561d82f (diff)
downloadkittybox-a18eb65b31676a7ee2a952437cc302265e5868da.tar.zst
ignore rsa false-positive via sqlx-mysql, since it's unused
Change-Id: Ic76cbc7f5343edad057b0eca121357c56d9c79ae
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index ce3991f..6979e89 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,6 @@
 { mkShell, rustc, cargo, rust-analyzer, clippy, rustfmt
 , cargo-watch, cargo-edit, cargo-outdated
-, cargo-crev, cargo-audit
+, cargo-crev, cargo-audit, cargo-whatfeatures
 , xh, systemfd, tokio-console, sqlx-cli
 , pkg-config, protobuf, openssl
 , nodePackages, caddy
@@ -12,6 +12,7 @@ mkShell {
     rustc cargo rust-analyzer clippy rustfmt
     cargo-watch cargo-edit cargo-outdated
     cargo-crev cargo-audit sqlx-cli
+    cargo-whatfeatures
     xh systemfd caddy
     # protobuf is required for tokio-console's console-subscriber
     #tokio-console protobuf