about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-11-13 04:11:34 +0300
committerVika <vika@fireburn.ru>2024-11-13 04:11:34 +0300
commit5b1318e8ed905eaa1b666cbc8300701ce7b5d061 (patch)
treea86d49bfc103016699de2b05f2daee83fe5e7f32 /shell.nix
parent7553d834d03bd4fa65dca24e1edc3e6a555ce9d2 (diff)
downloadkittybox-5b1318e8ed905eaa1b666cbc8300701ce7b5d061.tar.zst
shell.nix: take entire nodePackages
Change-Id: I9f0a88a20078603a8fbcf14a975878126bcdefcf
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index bf099b0..ce3991f 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,7 +3,7 @@
 , cargo-crev, cargo-audit
 , xh, systemfd, tokio-console, sqlx-cli
 , pkg-config, protobuf, openssl
-, typescript, typescript-language-server, caddy
+, nodePackages, caddy
 }:
 mkShell {
   name = "rust-dev-shell";
@@ -13,9 +13,10 @@ mkShell {
     cargo-watch cargo-edit cargo-outdated
     cargo-crev cargo-audit sqlx-cli
     xh systemfd caddy
-    typescript typescript-language-server
     # protobuf is required for tokio-console's console-subscriber
     #tokio-console protobuf
     pkg-config openssl
-  ];
+  ] ++ (with nodePackages; [
+    typescript typescript-language-server
+  ]);
 }