about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-07-07 00:36:52 +0300
committerVika <vika@fireburn.ru>2022-07-07 00:36:52 +0300
commit346b3e01a27f68c26581090357407bae73b27060 (patch)
tree68ebe4ffb74fd5a5b128bd6ee604cb844d5e6895 /shell.nix
parent7ddb7eddec3b928947b52f715aaf4821a818ebee (diff)
Add rustfmt to shell.nix
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 32cff3e..3f9627d 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,4 +1,4 @@
-{ mkShell, rustc, cargo, rust-analyzer, clippy
+{ mkShell, rustc, cargo, rust-analyzer, clippy, rustfmt
 , cargo-watch, cargo-edit, cargo-outdated
 , xh, systemfd, tokio-console
 , pkg-config, protobuf, openssl, zlib
@@ -7,7 +7,7 @@ mkShell {
   name = "rust-dev-shell";
 
   nativeBuildInputs = [
-    rustc cargo rust-analyzer clippy
+    rustc cargo rust-analyzer clippy rustfmt
     cargo-watch cargo-edit cargo-outdated
     xh systemfd tokio-console
     # required for tokio-console's console-subscriber