about summary refs log tree commit diff
path: root/kittybox-rs/indieauth/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-07-10 19:35:10 +0300
committerVika <vika@fireburn.ru>2022-07-10 19:35:10 +0300
commit9ca0e358dc95e7358815886b061288f04a7d29af (patch)
treebc19ac6071d75f1ae58069e577fc02692aa87c8b /kittybox-rs/indieauth/Cargo.toml
parent0ee2072d40dc0b88a7f475a25dfc790d49546a5f (diff)
kittybox-indieauth: init
This crate is the base framework-agnostic implementation of all data
structures and methods required for IndieAuth protocol. Anything that
can deserialize HTTP request payloads with serde can utilize this
crate.

This is a good candidate to independently release on crates.io when
the interface becomes stable enough.
Diffstat (limited to 'kittybox-rs/indieauth/Cargo.toml')
-rw-r--r--kittybox-rs/indieauth/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/kittybox-rs/indieauth/Cargo.toml b/kittybox-rs/indieauth/Cargo.toml
new file mode 100644
index 0000000..222d706
--- /dev/null
+++ b/kittybox-rs/indieauth/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "kittybox-indieauth"
+version = "0.1.0"
+edition = "2021"
+
+[dev-dependencies]
+serde_json = "^1.0.64"       # A JSON serialization file format
+
+[dependencies]
+rand = "^0.8.5"              # Utilities for random number generation
+data-encoding = "^2.3.2"     # Efficient and customizable data-encoding functions like base64, base32, and hex
+sha2 = "^0.9.8"              # SHA-2 series of algorithms for Rust
+[dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
+version = "^2.2.1"
+features = ["serde"]
+[dependencies.serde]         # A generic serialization/deserialization framework
+version = "^1.0.125"
+features = ["derive"]