about summary refs log tree commit diff
path: root/kittybox-rs/indieauth/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-07-09 22:22:34 +0300
committerVika <vika@fireburn.ru>2023-07-17 01:53:42 +0300
commit99ff9cdc6890959cd4d2112c2e37b97ae83cb43c (patch)
tree31cdaf82de9d95ad4ee857f9148ad442f67db23d /kittybox-rs/indieauth/Cargo.toml
parentdc7dfc61ec839175ebb51fcbaef1156fea5fdcf4 (diff)
cargo update, part 2: Axum
Axum got some breaking changes and gained some nice features —
however, features come later, breaking changes come first.

Perhaps it would be nice to actually construct a State with all of my
stuff, and then make functions generic over that. Could reduce the
amount of generic stuff I am producing... maybe.
Diffstat (limited to 'kittybox-rs/indieauth/Cargo.toml')
-rw-r--r--kittybox-rs/indieauth/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/kittybox-rs/indieauth/Cargo.toml b/kittybox-rs/indieauth/Cargo.toml
index 332584d..d6bc1fe 100644
--- a/kittybox-rs/indieauth/Cargo.toml
+++ b/kittybox-rs/indieauth/Cargo.toml
@@ -21,7 +21,7 @@ features = ["serde"]
 version = "^1.0.170"
 features = ["derive"]
 [dependencies.axum-core]
-version = "^0.2.6"
+version = "^0.3.4"
 optional = true
 [dependencies.serde_json]
 version = "^1.0.64"