about summary refs log tree commit diff
path: root/kittybox-rs/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-08-13 21:54:53 +0300
committerVika <vika@fireburn.ru>2022-08-13 21:54:53 +0300
commit3de3fc65d131fc84512fcd4b1f25f64a0860e6db (patch)
treec945a7c2e6f8f2a2884f082f1af8c63f9ba9dd92 /kittybox-rs/Cargo.toml
parentfde3e415b3412984d33281b28710e0c2b0c9b137 (diff)
tokenauth: migrate tests to Wiremock
Wiremock doesn't require external C dependencies.
Diffstat (limited to 'kittybox-rs/Cargo.toml')
-rw-r--r--kittybox-rs/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/kittybox-rs/Cargo.toml b/kittybox-rs/Cargo.toml
index 4ed65b3..b82b2a9 100644
--- a/kittybox-rs/Cargo.toml
+++ b/kittybox-rs/Cargo.toml
@@ -45,7 +45,7 @@ features = ["axum"]
 [dev-dependencies]
 mockito = "^0.30.0"          # HTTP mocking for Rust.
 tempdir = "^0.3.7"           # A library for managing a temporary directory and deleting all contents when it's dropped
-httpmock = "^0.6"            # HTTP mocking library that allows you to simulate responses from HTTP based services
+wiremock = "^0.5.14"
 faker_rand = "^0.1.1"        # Seedable, rand-compatible generators of fake data
 rand = "^0.8.5"              # Utilities for random number generation
 tracing-test = "^0.2.2"