about summary refs log tree commit diff
path: root/kittybox-rs/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-07-10 00:55:20 +0300
committerVika <vika@fireburn.ru>2022-07-10 00:55:20 +0300
commit1031d495d5b78d9b19dcdc414b6d7b0daf313bb2 (patch)
treea6ea6d347bc690c467df798f5576800d371b2254 /kittybox-rs/Cargo.toml
parent2cbd19693115bf19da0ab888372cb1ff086967cd (diff)
media: media endpoint PoC
Supported features:
 - Streaming upload
 - Content-addressed storage
 - Metadata
   - MIME type (taken from Content-Type)
   - Length (I could use stat() for this one tho)
   - filename (for Content-Disposition: attachment, WIP)
Diffstat (limited to 'kittybox-rs/Cargo.toml')
-rw-r--r--kittybox-rs/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/kittybox-rs/Cargo.toml b/kittybox-rs/Cargo.toml
index 99e3097..6234865 100644
--- a/kittybox-rs/Cargo.toml
+++ b/kittybox-rs/Cargo.toml
@@ -54,6 +54,7 @@ easy-scraper = "^0.2.0"      # HTML scraping library focused on ease of use
 either = "^1.6.1"            # A general purpose sum type with two cases
 futures = "^0.3.14"          # An implementation of futures and streams
 futures-util = "^0.3.14"     # Common utilities and extension traits for the futures-rs library
+hex = "^0.4.3"
 lazy_static = "^1.4.0"       # A macro for declaring lazily evaluated statics in Rust
 listenfd = "^0.5.0"          # A simple library to work with listenfds passed from the outside (systemd/catflap socket activation)
 log = "^0.4.14"              # A lightweight logging facade for Rust