about summary refs log tree commit diff
path: root/indieauth/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-07-29 21:59:56 +0300
committerVika <vika@fireburn.ru>2023-07-29 21:59:56 +0300
commit0617663b249f9ca488e5de652108b17d67fbaf45 (patch)
tree11564b6c8fa37bf9203a0a4cc1c4e9cc088cb1a5 /indieauth/Cargo.toml
parent26c2b79f6a6380ae3224e9309b9f3352f5717bd7 (diff)
Moved the entire Kittybox tree into the root
Diffstat (limited to 'indieauth/Cargo.toml')
-rw-r--r--indieauth/Cargo.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/indieauth/Cargo.toml b/indieauth/Cargo.toml
new file mode 100644
index 0000000..d6bc1fe
--- /dev/null
+++ b/indieauth/Cargo.toml
@@ -0,0 +1,31 @@
+[package]
+name = "kittybox-indieauth"
+version = "0.1.0"
+edition = "2021"
+
+[features]
+default = []
+axum = ["axum-core", "serde_json", "http"]
+
+[dev-dependencies]
+serde_json = "^1.0.64"       # A JSON serialization file format
+serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
+[dependencies]
+rand = "^0.8.5"              # Utilities for random number generation
+data-encoding = "^2.3.2"     # Efficient and customizable data-encoding functions like base64, base32, and hex
+sha2 = "^0.10.7"              # SHA-2 series of algorithms for Rust
+[dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
+version = "^2.2.1"
+features = ["serde"]
+[dependencies.serde]         # A generic serialization/deserialization framework
+version = "^1.0.170"
+features = ["derive"]
+[dependencies.axum-core]
+version = "^0.3.4"
+optional = true
+[dependencies.serde_json]
+version = "^1.0.64"
+optional = true
+[dependencies.http]
+version = "^0.2.7"
+optional = true
\ No newline at end of file