about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorVika Shleina <vika@fireburn.ru>2021-07-15 04:32:29 +0300
committerVika <vika@fireburn.ru>2021-07-19 04:57:11 +0300
commitd399fd0bd00c9ea073e5b057de70c9ffdd9356f8 (patch)
treea9dafbeb62fb2aeb56e2d190565c70cd7f4b9d7a /flake.nix
parent93b56879298810d60d121203403e2416f35e4765 (diff)
Renamed main executable to kittybox, added tools
The new tools are:
 - kittybox-bulk-import, a bare-bones Micropub client that reads a JSON
   list of posts and then sends them one by one to the Micropub endpoint
 - pyindieblog-export, my personal tool which directly connects to
   Pyindieblog's redis instance and extracts data from it in JSON format
   suitable for use with kittybox-bulk-import.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/flake.nix b/flake.nix
index a24981e..b05e05c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -35,8 +35,8 @@
           };
           package = mkOption {
             type = types.package;
-            default = self.packages.${config.nixpkgs.localSystem.system}.kittybox-micropub;
-            defaultText = "<kittybox_micropub package from the official flake>";
+            default = self.packages.${config.nixpkgs.localSystem.system}.kittybox;
+            defaultText = "<kittybox package from the official flake>";
             description = "Which Kittybox derivation to use.";
           };
 
@@ -98,7 +98,7 @@
           };
 
           serviceConfig = {
-            ExecStart = "${cfg.package}/bin/kittybox_micropub";
+            ExecStart = "${cfg.package}/bin/kittybox";
             DynamicUser = true;
           };
         };
@@ -114,9 +114,9 @@
     };
     rust-bin = pkgs.rust-bin.stable.latest;
     packages = {
-      kittybox-micropub = { stdenv, lib, redis, naersk-lib }:
+      kittybox = { stdenv, lib, redis, naersk-lib }:
       naersk-lib.buildPackage {
-        pname = "kittybox-micropub";
+        pname = "kittybox";
         version = "0.1.0";
 
         src = ./.;
@@ -127,7 +127,7 @@
         meta = with lib.meta; {
           maintainers = with maintainers; [ vika_nezrimaya ];
           platforms = supportedSystems;
-          mainProgram = "kittybox_micropub";
+          mainProgram = "kittybox";
         };
       };
     };
@@ -138,9 +138,9 @@
         cargo = pkgs.rust-bin.nightly.latest.minimal;
       };
     in {
-      kittybox-micropub = pkgs.callPackage packages.kittybox-micropub { inherit naersk-lib; };
+      kittybox = pkgs.callPackage packages.kittybox { inherit naersk-lib; };
     };
-    defaultPackage = self.packages.${system}.kittybox-micropub;
+    defaultPackage = self.packages.${system}.kittybox;
 
     checks = {
       nixos-test = pkgs.nixosTest ({ lib }: {