about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-03-02 23:33:21 +0300
committerVika <vika@fireburn.ru>2022-03-02 23:33:21 +0300
commit9c3deefd40135a4127632fb37e6b61a10949ea9f (patch)
tree2fc1c841968dac6caa6273873263840c29c0c0cc /flake.nix
parent56d7a24da22a08a27a6ea810c5fb10daff81e595 (diff)
update dev script to use systemfd and cargo-watch
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index c1827cd..2e1966b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -262,8 +262,9 @@
       name = "rust-dev-shell";
       nativeBuildInputs = with pkgs; [
         pkg-config lld
-        # required for httpmock, not actually used
+        # required for httpmock, not actually used in the release
         openssl.dev
+        httpie systemfd cargo-watch
         (rust-bin.default.override { extensions = [ "rust-src" ]; })
         (rust-analyzer.override { rustPlatform = with rust-bin; { rustLibSrc = rust-src; }; })
       ];