about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-05-26 00:19:33 +0300
committerVika <vika@fireburn.ru>2022-05-26 00:19:33 +0300
commit8eedee638a5cc54b03baedea3697280eef719469 (patch)
treefd516629bfb56fe86dcf321061fa8974de50c9b9 /flake.nix
parent256ba343a05bc93e576837b75b8739c0fb5ed5cd (diff)
flake.nix: move the devShell into its own file
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 1 insertions, 13 deletions
diff --git a/flake.nix b/flake.nix
index 165b386..5c3ed37 100644
--- a/flake.nix
+++ b/flake.nix
@@ -40,18 +40,6 @@
       };
     };
 
-    devShells.default = pkgs.mkShell {
-      name = "rust-dev-shell";
-
-      nativeBuildInputs = with pkgs; [
-        # required for tokio-console's console-subscriber
-        pkg-config protobuf
-        # required for httpmock, not actually used in the release
-        openssl.dev zlib
-        xh systemfd tokio-console
-        cargo-watch cargo-edit cargo-outdated
-        rustc cargo rust-analyzer clippy
-      ];
-    };
+    devShells.default = pkgs.callPackage ./shell.nix {};
   });
 }