about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika Shleina <vika@fireburn.ru>2021-07-15 04:32:29 +0300
committerVika <vika@fireburn.ru>2021-07-19 04:57:11 +0300
commitd399fd0bd00c9ea073e5b057de70c9ffdd9356f8 (patch)
treea9dafbeb62fb2aeb56e2d190565c70cd7f4b9d7a /Cargo.toml
parent93b56879298810d60d121203403e2416f35e4765 (diff)
Renamed main executable to kittybox, added tools
The new tools are:
 - kittybox-bulk-import, a bare-bones Micropub client that reads a JSON
   list of posts and then sends them one by one to the Micropub endpoint
 - pyindieblog-export, my personal tool which directly connects to
   Pyindieblog's redis instance and extracts data from it in JSON format
   suitable for use with kittybox-bulk-import.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 14 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 52095fb..b07da8a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,9 +1,22 @@
 [package]
-name = "kittybox_micropub"
+name = "kittybox"
 version = "0.1.0"
 authors = ["Vika <vika@fireburn.ru>"]
 edition = "2018"
 
+[features]
+default = ["util"]
+util = ["anyhow"]
+
+[[bin]]
+name = "kittybox-bulk-import"
+path = "src/bin/kittybox_bulk_import.rs"
+required-features = ["util"]
+
+[[bin]]
+name = "pyindieblog-export"
+path = "src/bin/pyindieblog_to_kittybox.rs"
+required-features = ["util"]
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [dev-dependencies]