about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-12-30 23:28:50 +0300
committerVika <vika@fireburn.ru>2024-12-30 23:28:50 +0300
commitc9cab223d4e713235e290e786d83befe1802012e (patch)
treed9c65403066e56b7487cd501a1f7a5b0692719df /Cargo.toml
parente1d84a071e6b61060d57e100fe86580d0aab9846 (diff)
downloadkittybox-c9cab223d4e713235e290e786d83befe1802012e.tar.zst
cargo upgrade
Change-Id: I3c02e42596d9e307e4f155959ea5f1493322df82
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml80
1 files changed, 40 insertions, 40 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 57888a5..15e0503 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -69,39 +69,39 @@ features = ["axum"]
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [dev-dependencies]
-tempfile = "^3.4.0"          # Temporary file managment
-wiremock = "^0.6.1"
+tempfile = "^3.14.0"          # Temporary file managment
+wiremock = "^0.6.2"
 faker_rand = "^0.1.1"        # Seedable, rand-compatible generators of fake data
 rand = "^0.8.5"              # Utilities for random number generation
-tracing-test = "^0.2.2"
+tracing-test = "^0.2.5"
 
 [dependencies]
-argon2 = { version = "^0.5.0", features = ["std"] }
-async-trait = "^0.1.50"      # Type erasure for async trait methods
-bytes = "^1.1.0"
-data-encoding = "^2.3.2"     # Efficient and customizable data-encoding functions like base64, base32, and hex
+argon2 = { version = "^0.5.3", features = ["std"] }
+async-trait = "^0.1.83"      # Type erasure for async trait methods
+bytes = "^1.9.0"
+data-encoding = "^2.6.0"     # Efficient and customizable data-encoding functions like base64, base32, and hex
 easy-scraper = "^0.2.0"      # HTML scraping library focused on ease of use
-either = "^1.6.1"            # A general purpose sum type with two cases
-futures = "^0.3.14"          # An implementation of futures and streams
-futures-util = "^0.3.14"     # Common utilities and extension traits for the futures-rs library
+either = "^1.13.0"            # A general purpose sum type with two cases
+futures = "^0.3.31"          # An implementation of futures and streams
+futures-util = "^0.3.31"     # Common utilities and extension traits for the futures-rs library
 hex = "^0.4.3"
-lazy_static = "^1.4.0"       # A macro for declaring lazily evaluated statics in Rust
+lazy_static = "^1.5.0"       # A macro for declaring lazily evaluated statics in Rust
 listenfd = "^1.0.1"          # A simple library to work with listenfds passed from the outside (systemd/catflap socket activation)
-markdown = "^1.0.0-alpha.7"  # Native Rust library for parsing Markdown and (outputting HTML)
-newbase60 = "^0.1.3"         # A library that implements Tantek Çelik's New Base 60
-rand = "^0.8.4"              # Random number generators.
-serde_json = "^1.0.64"       # A JSON serialization file format
-serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
-serde_variant = "^0.1.1"     # Retrieve serde provided variant names for enum objects
-relative-path = "^1.5.0"     # Portable relative paths for Rust
-sha2 = "^0.10.7"              # SHA-2 series of algorithms for Rust
-uuid = { version = "^1.3.3", features = [ "v4" ] }
-tracing = { version = "0.1.34", features = [] }
+markdown = "^1.0.0-alpha.21"  # Native Rust library for parsing Markdown and (outputting HTML)
+newbase60 = "^0.1.4"         # A library that implements Tantek Çelik's New Base 60
+rand = "^0.8.5"              # Random number generators.
+serde_json = "^1.0.134"       # A JSON serialization file format
+serde_urlencoded = "^0.7.1"  # `x-www-form-urlencoded` meets Serde
+serde_variant = "^0.1.3"     # Retrieve serde provided variant names for enum objects
+relative-path = "^1.9.3"     # Portable relative paths for Rust
+sha2 = "^0.10.8"              # SHA-2 series of algorithms for Rust
+uuid = { version = "^1.11.0", features = [ "v4" ] }
+tracing = { version = "0.1.41", features = [] }
 tracing-tree = "0.4.0"
 tracing-log = "0.2.0"
-tracing-subscriber = { version = "0.3.11", features = ["env-filter", "json"] }
-tower-http = { version = "0.5.0", features = ["trace", "cors", "catch-panic", "sensitive-headers"] }
-tower = { version = "0.4.12", features = ["tracing"] }
+tracing-subscriber = { version = "0.3.19", features = ["env-filter", "json"] }
+tower-http = { version = "0.5.2", features = ["trace", "cors", "catch-panic", "sensitive-headers"] }
+tower = { version = "0.4.13", features = ["tracing"] }
 webauthn = { version = "0.5.0", package = "webauthn-rs", features = ["danger-allow-state-serialisation"], optional = true }
 base64 = "0.22.1"
 html5ever = "0.27.0"
@@ -109,58 +109,58 @@ mime = "0.3.17"
 http-cache-reqwest = { version = "0.14.0", default-features = false, features = ["manager-moka"] }
 reqwest-middleware = "0.3.3"
 [dependencies.tokio]
-version = "^1.29.1"
+version = "^1.42.0"
 features = ["full", "tracing"] # TODO determine if my app doesn't need some features
 #[dependencies.console-subscriber]
 #version = "0.1.10"
 [dependencies.tokio-stream]
-version = "^0.1.8"
+version = "^0.1.17"
 features = ["time", "net"]
 [dependencies.tokio-util]
-version = "^0.7.3"
+version = "^0.7.13"
 features = ["io-util"]
 [dependencies.anyhow]
-version = "^1.0.42"
+version = "^1.0.95"
 optional = true
 [dependencies.axum]
-version = "^0.7.5"
+version = "^0.7.9"
 features = ["multipart", "json", "form", "macros"]
 [dependencies.axum-extra]
-version = "^0.9.3"
+version = "^0.9.6"
 features = ["cookie", "cookie-signed", "typed-header"]
 [dependencies.chrono]        # Date and time library for Rust
-version = "^0.4.19"
+version = "^0.4.39"
 features = ["serde"]
 [dependencies.redis]
-version = "^0.26.0"
+version = "^0.26.1"
 optional = true
 features = ["aio", "tokio-comp"]
 [dependencies.prometheus]    # Prometheus instrumentation library for Rust applications
-version = "^0.13.0"
+version = "^0.13.4"
 features = ["process"]
 [dependencies.serde]         # A generic serialization/deserialization framework
-version = "^1.0.170"
+version = "^1.0.217"
 features = ["derive"]
 [dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
-version = "^2.2.1"
+version = "^2.5.4"
 features = ["serde"]
 [dependencies.hyper]
-version = "^1.4.1"
+version = "^1.5.2"
 features = []
 [dependencies.reqwest]
-version = "^0.12.5"
+version = "^0.12.11"
 default-features = false
 features = ["gzip", "brotli", "json", "stream"]
 [dependencies.microformats]
-version = "^0.12.0"
+version = "=0.12.0"
 #git = "https://gitlab.com/maxburon/microformats-parser"
 
 [dependencies.clap]
-version = "4.3.11"
+version = "4.5.23"
 features = ["derive"]
 optional = true
 [dependencies.thiserror]
-version = "1.0.35"
+version = "1.0.69"
 [dependencies.sqlx]
 version = "^0.8"
 features = ["uuid", "chrono", "json", "postgres", "runtime-tokio"]