about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-05-24 17:18:30 +0300
committerVika <vika@fireburn.ru>2022-05-24 17:18:30 +0300
commit5610a5f0bf1a9df02bd3d5b55e2cdebef2440360 (patch)
tree8394bcf1dcc204043d7adeb8dde2e2746977606e /Cargo.toml
parent2f93873122b47e42f7ee1c38f1f04d052a63599c (diff)
flake.nix: reorganize
 - Kittybox's source code is moved to a subfolder
   - This improves build caching by Nix since it doesn't take changes
     to other files into account
 - Package and test definitions were spun into separate files
   - This makes my flake.nix much easier to navigate
   - This also makes it somewhat possible to use without flakes (but
     it is still not easy, so use flakes!)
 - Some attributes were moved in compliance with Nix 2.8's changes to
   flake schema
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml114
1 files changed, 0 insertions, 114 deletions
diff --git a/Cargo.toml b/Cargo.toml
deleted file mode 100644
index d43f0f4..0000000
--- a/Cargo.toml
+++ /dev/null
@@ -1,114 +0,0 @@
-[package]
-name = "kittybox"
-version = "0.1.0"
-authors = ["Vika <vika@fireburn.ru>"]
-edition = "2021"
-default-run = "kittybox"
-
-[features]
-default = []
-util = ["anyhow"]
-
-[[bin]]
-name = "kittybox-bulk-import"
-path = "src/bin/kittybox_bulk_import.rs"
-required-features = ["util"]
-
-[[bin]]
-name = "pyindieblog-export"
-path = "src/bin/pyindieblog_to_kittybox.rs"
-required-features = ["util", "redis"]
-
-[[bin]]
-name = "kittybox-database-converter"
-path = "src/bin/kittybox_database_converter.rs"
-required-features = ["util", "redis"]
-
-[workspace]
-members = [".", "./util", "./templates"]
-default-members = [".", "./util", "./templates"]
-[dependencies.kittybox-util]
-version = "0.1.0"
-path = "./util"
-[dependencies.kittybox-templates]
-version = "0.1.0"
-path = "./templates"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dev-dependencies]
-mockito = "^0.30.0"          # HTTP mocking for Rust.
-tempdir = "^0.3.7"           # A library for managing a temporary directory and deleting all contents when it's dropped
-test-logger = "^0.1.0"       # Simple helper to initialize env_logger before unit and integration tests
-httpmock = "^0.6"            # HTTP mocking library that allows you to simulate responses from HTTP based services
-faker_rand = "^0.1.1"        # Seedable, rand-compatible generators of fake data
-rand = "^0.8.5"              # Utilities for random number generation
-
-[dependencies]
-async-trait = "^0.1.50"      # Type erasure for async trait methods
-bytes = "^1.1.0"
-data-encoding = "^2.3.2"     # Efficient and customizable data-encoding functions like base64, base32, and hex
-easy-scraper = "^0.2.0"      # HTML scraping library focused on ease of use
-either = "^1.6.1"            # A general purpose sum type with two cases
-env_logger = "^0.8.3"        # A logging implementation for `log` which is configured via an environment variable
-futures = "^0.3.14"          # An implementation of futures and streams
-futures-util = "^0.3.14"     # Common utilities and extension traits for the futures-rs library
-lazy_static = "^1.4.0"       # A macro for declaring lazily evaluated statics in Rust
-listenfd = "^0.5.0"          # A simple library to work with listenfds passed from the outside (systemd/catflap socket activation)
-log = "^0.4.14"              # A lightweight logging facade for Rust
-markdown = "^0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
-markup = "^0.12.0"           # HTML templating engine... ok also very funny about markdown and markup... i just realized the pun...
-mediatype = "^0.19.1"        # MIME Media-type parsing
-newbase60 = "^0.1.3"         # A library that implements Tantek Çelik's New Base 60
-rand = "^0.8.4"              # Random number generators.
-retainer = "^0.2.2"          # Minimal async cache in Rust with support for key expirations
-serde_json = "^1.0.64"       # A JSON serialization file format
-serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
-serde_variant = "^0.1.1"     # Retrieve serde provided variant names for enum objects
-relative-path = "^1.5.0"     # Portable relative paths for Rust
-sha2 = "^0.9.8"              # SHA-2 series of algorithms for Rust
-warp-prometheus = "^0.5.0"   # An afterthought of prometheus metrics for Warp
-[dependencies.tokio]
-version = "^1.16.1"
-features = ["full", "tracing"] # TODO determine if my app doesn't need some features
-[dependencies.console-subscriber]
-version = "0.1.3"
-[dependencies.tokio-stream]
-version = "^0.1.8"
-features = ["time", "net"]
-[dependencies.anyhow]
-version = "^1.0.42"
-optional = true
-[dependencies.chrono]        # Date and time library for Rust
-version = "^0.4.19"
-features = ["serde"]
-[dependencies.redis]
-version = "^0.21.3"
-optional = true
-features = ["aio", "tokio-comp"]
-[dependencies.prometheus]    # Prometheus instrumentation library for Rust applications
-version = "^0.13.0"
-features = ["process"]
-[dependencies.serde]         # A generic serialization/deserialization framework
-version = "^1.0.125"
-features = ["derive"]
-[dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
-version = "^2.2.1"
-features = ["serde"]
-[dependencies.warp]
-version = "^0.3.2"
-default-features = false
-features = ["multipart", "compression"]
-[dependencies.http-types]    # Common types for HTTP operations
-version = "^2.11.0"
-features = ["http"]
-[dependencies.hyper]
-version = "^0.14.17"
-features = ["stream", "runtime"]
-[dependencies.reqwest]
-version = "^0.11.10"
-default-features = false
-features = ["rustls-tls-webpki-roots", "gzip", "brotli", "json", "stream"]
-[dependencies.microformats]
-version = "^0.2.0"
-#git = "https://gitlab.com/maxburon/microformats-parser"