about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2021-05-10 15:56:20 +0300
committerVika <vika@fireburn.ru>2021-05-10 16:46:16 +0300
commit552176ed31f6e20b4e3391e37a035b556500d6f2 (patch)
treee871cf41979369d6be92b216cb0459bc5eb96ffd /Cargo.toml
parentd50e6e54975a3a39ebfb252676d7f7857d588cab (diff)
Removed openssl dependency - now the code is pure Rust
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 83ff9ab..de17d38 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,7 +28,6 @@ newbase60 = "0.1.3"         # A library that implements Tantek Çelik's New Base
 retainer = "0.2.2"          # Minimal async cache in Rust with support for key expirations
 serde_json = "1.0.64"       # A JSON serialization file format
 serde_urlencoded = "0.7.0"  # `x-www-form-urlencoded` meets Serde
-surf = "2.2.0"              # Surf the web - HTTP client framework
 tide = "0.16.0"             # A minimal and pragmatic Rust web application framework built for rapid development
 [dependencies.async-std]    # Async version of the Rust standard library
 version = "1.9.0"
@@ -43,6 +42,10 @@ default-features = false
 [dependencies.serde]        # A generic serialization/deserialization framework
 version = "1.0.125"
 features = ["derive"]
+[dependencies.surf]         # Surf the web - HTTP client framework
+version = "2.2.0"
+default-features = false
+features = ["h1-client-rustls", "encoding", "middleware-logger"]
 [dependencies.url]          # URL library for Rust, based on the WHATWG URL Standard
 version = "2.2.1"
 features = ["serde"]