about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-08-01 22:50:28 +0300
committerVika <vika@fireburn.ru>2024-08-02 16:13:39 +0300
commit2318a33f9b359ae27b52cd9a19db1f6782d8dae3 (patch)
tree5f4dc1ad73d5c4104679a1976781861ec23cb20e /Cargo.toml
parent61a6bf6b80aea18d8b7af159d504004a29e50576 (diff)
Upgrade dependencies and fix deprecated functionality
I think I managed to not lose any functionality from my dependencies.

sqlparser remains unupgraded, but that's mostly because it is only
used in one example and it's not worth it to upgrade right now.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml38
1 files changed, 19 insertions, 19 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 974bb67..9062cfe 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,7 @@ default = ["rustls", "postgres"]
 #util = ["anyhow"]
 #migration = ["util"]
 webauthn = ["openssl", "dep:webauthn"]
-openssl = ["reqwest/native-tls-crate", "reqwest/native-tls-alpn", "sqlx/tls-native-tls"]
+openssl = ["reqwest/native-tls", "reqwest/native-tls-alpn", "sqlx/tls-native-tls"]
 rustls = ["reqwest/rustls-tls-webpki-roots", "sqlx/tls-rustls"]
 cli = ["clap"]
 postgres = ["sqlx", "kittybox-util/sqlx"]
@@ -71,7 +71,7 @@ features = ["axum"]
 
 [dev-dependencies]
 tempfile = "^3.4.0"          # Temporary file managment
-wiremock = "^0.5.14"
+wiremock = "^0.6.1"
 faker_rand = "^0.1.1"        # Seedable, rand-compatible generators of fake data
 rand = "^0.8.5"              # Utilities for random number generation
 tracing-test = "^0.2.2"
@@ -87,8 +87,7 @@ futures = "^0.3.14"          # An implementation of futures and streams
 futures-util = "^0.3.14"     # Common utilities and extension traits for the futures-rs library
 hex = "^0.4.3"
 lazy_static = "^1.4.0"       # A macro for declaring lazily evaluated statics in Rust
-listenfd = "^0.5.0"          # A simple library to work with listenfds passed from the outside (systemd/catflap socket activation)
-#log = "^0.4.14"              # A lightweight logging facade for Rust
+listenfd = "^1.0.1"          # A simple library to work with listenfds passed from the outside (systemd/catflap socket activation)
 markdown = "^1.0.0-alpha.7"  # Native Rust library for parsing Markdown and (outputting HTML)
 newbase60 = "^0.1.3"         # A library that implements Tantek Çelik's New Base 60
 rand = "^0.8.4"              # Random number generators.
@@ -99,13 +98,14 @@ relative-path = "^1.5.0"     # Portable relative paths for Rust
 sha2 = "^0.10.7"              # SHA-2 series of algorithms for Rust
 uuid = "^1.3.3"
 tracing = { version = "0.1.34", features = [] }
-tracing-tree = "0.2.1"
-tracing-log = "0.1.3"
+tracing-tree = "0.4.0"
+tracing-log = "0.2.0"
 tracing-subscriber = { version = "0.3.11", features = ["env-filter", "json"] }
-tower-http = { version = "0.3.3", features = ["trace", "cors", "catch-panic", "sensitive-headers"] }
+tower-http = { version = "0.5.0", features = ["trace", "cors", "catch-panic", "sensitive-headers"] }
 tower = { version = "0.4.12", features = ["tracing"] }
-webauthn = { version = "0.4.5", package = "webauthn-rs", features = ["danger-allow-state-serialisation"], optional = true }
-base64 = "0.21.2"
+webauthn = { version = "0.5.0", package = "webauthn-rs", features = ["danger-allow-state-serialisation"], optional = true }
+base64 = "0.22.1"
+html5ever = "0.27.0"
 [dependencies.tokio]
 version = "^1.29.1"
 features = ["full", "tracing"] # TODO determine if my app doesn't need some features
@@ -121,16 +121,16 @@ features = ["io-util"]
 version = "^1.0.42"
 optional = true
 [dependencies.axum]
-version = "^0.6.18"
-features = ["multipart", "json", "headers", "form", "macros"]
+version = "^0.7.5"
+features = ["multipart", "json", "form", "macros"]
 [dependencies.axum-extra]
-version = "^0.7.4"
-features = ["cookie", "cookie-signed"]
+version = "^0.9.3"
+features = ["cookie", "cookie-signed", "typed-header"]
 [dependencies.chrono]        # Date and time library for Rust
 version = "^0.4.19"
 features = ["serde"]
 [dependencies.redis]
-version = "^0.21.3"
+version = "^0.26.0"
 optional = true
 features = ["aio", "tokio-comp"]
 [dependencies.prometheus]    # Prometheus instrumentation library for Rust applications
@@ -143,14 +143,14 @@ features = ["derive"]
 version = "^2.2.1"
 features = ["serde"]
 [dependencies.hyper]
-version = "^0.14.17"
-features = ["stream", "runtime"]
+version = "^1.4.1"
+features = []
 [dependencies.reqwest]
-version = "^0.11.10"
+version = "^0.12.5"
 default-features = false
 features = ["gzip", "brotli", "json", "stream"]
 [dependencies.microformats]
-version = "^0.3.0"
+version = "^0.9.1"
 #git = "https://gitlab.com/maxburon/microformats-parser"
 
 [dependencies.clap]
@@ -160,7 +160,7 @@ optional = true
 [dependencies.thiserror]
 version = "1.0.35"
 [dependencies.sqlx]
-version = "^0.7"
+version = "^0.8"
 features = ["uuid", "chrono", "json", "postgres", "runtime-tokio"]
 optional = true
 [dependencies.sqlparser]