about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2021-08-06 09:23:02 +0300
committerVika <vika@fireburn.ru>2021-08-06 09:53:21 +0300
commit1c1d0e504c276ccb3c204aa28750f86610bff248 (patch)
tree95d061e7977482a93fba42a4ae93b10e982f1f9e /Cargo.toml
parent77d9284e1debcd1db3ac1604cb2f0552f6609c91 (diff)
Moved mobc to a custom repo
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 18 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 79f7107..7418d90 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,6 +19,9 @@ path = "src/bin/pyindieblog_to_kittybox.rs"
 required-features = ["util"]
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
+[patch.crates-io]
+mobc = { git = 'https://github.com/kisik21/mobc' }
+
 [dev-dependencies]
 tide-testing = "^0.1.3"      # tide testing helper
 mockito = "^0.30.0"          # HTTP mocking for Rust.
@@ -36,32 +39,45 @@ lazy_static = "^1.4.0"       # A macro for declaring lazily evaluated statics in
 log = "^0.4.14"              # A lightweight logging facade for Rust
 markdown = "^0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
 markup = "^0.12.0"           # HTML templating engine... ok also very funny about markdown and markup... i just realized the pun...
-mobc = "^0.7.2"              # A generic connection pool with async/await support
 newbase60 = "^0.1.3"         # A library that implements Tantek Çelik's New Base 60
+#prometheus = "^0.12.0"       # Prometheus instrumentation library for Rust applications
 retainer = "^0.2.2"          # Minimal async cache in Rust with support for key expirations
 serde_json = "^1.0.64"       # A JSON serialization file format
 serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
 tide = "^0.16.0"             # A minimal and pragmatic Rust web application framework built for rapid development
+
 [dependencies.anyhow]
 version = "^1.0.42"
 optional = true
+
 [dependencies.async-std]     # Async version of the Rust standard library
 version = "^1.9.0"
 features = ["attributes"]
+
 [dependencies.chrono]        # Date and time library for Rust
 version = "^0.4.19"
 features = ["serde"]
+
+[dependencies.mobc]          # A generic connection pool with async/await support
+version = "^0.7.2"
+default-features = false
+features = ["async-std", "unstable"]
+
 [dependencies.mobc-redis]    # Redis support for the mobc connection pool
 version = "^0.7.0"
-features = ["async-std-comp"]
 default-features = false
+features = ["async-std-comp"]
+
 [dependencies.serde]         # A generic serialization/deserialization framework
 version = "^1.0.125"
 features = ["derive"]
+
 [dependencies.surf]          # Surf the web - HTTP client framework
 version = "^2.2.0"
 default-features = false
 features = ["h1-client-rustls", "encoding", "middleware-logger"]
+
 [dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
 version = "^2.2.1"
 features = ["serde"]
+