summary refs log tree commit diff
path: root/meson.build
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2025-01-30 09:51:33 +0300
committerVika <vika@fireburn.ru>2025-01-30 09:51:33 +0300
commit29568a14b389049480591e67a116400d030e8db1 (patch)
tree64048c64f9b24921e35b707bf1b76298480764fe /meson.build
parent62263e0e619625f2c5dd0b4364b43bd4fefc8ccd (diff)
downloadbowl-29568a14b389049480591e67a116400d030e8db1.tar.zst
Provide an application icon
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index cc832f5..1e57bd9 100644
--- a/meson.build
+++ b/meson.build
@@ -61,6 +61,12 @@ subdir('src')
 subdir('po')
 subdir('data')
 
+install_data(
+  meson.project_source_root() / 'icons' / 'bowl.svg',
+  install_dir: iconsdir / 'hicolor' / 'scalable' / 'apps',
+  rename: '@0@.svg'.format(application_id)
+)
+
 gnome.post_install(
   gtk_update_icon_cache: false,
   glib_compile_schemas: true,