summary refs log tree commit diff
path: root/libsecret/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-10-22 21:52:10 +0300
committerVika <vika@fireburn.ru>2024-10-22 21:52:10 +0300
commitf2f7b6ffec7bf657966353c850d25c6ab218ff7c (patch)
treed4d5cc76474453863a064eb04d75af5353579f5b /libsecret/Cargo.toml
parent3bd499a9d696a850a493bf81c01c68aee18c9d7b (diff)
downloadbowl-f2f7b6ffec7bf657966353c850d25c6ab218ff7c.tar.zst
vendor libsecret
The libsecret-rs crate is unmaintained, so I'm vendoring it for
now. Bumping the glib version turned out to be enough.

The exact process I used was:
1. Cloning the repository
2. Making changes
3. `cargo build` to ensure it works
4. `cargo package --no-verify` (b/c it tries to build all crates
separately instead of the entire workspace as a whole)
5. `mkdir libsecret/sys -p`
6. `tar --strip-components 1 -C libsecret -xvf ../libsecret-rs/target/package/libsecret-0.6.0.crate`
7. `tar --strip-components 1 -C libsecret/sys -xvf ../libsecret-rs/target/package/libsecret-sys-0.6.0.crate`

Then `Cargo.toml` is modified to ensure the libsecret and its `-sys`
crate build out of my vendored sources.

In the future, if I gain maintainership of the `libsecret` crate, I
could just revert this commit to make it point back to the upstream.
Diffstat (limited to 'libsecret/Cargo.toml')
-rw-r--r--libsecret/Cargo.toml95
1 files changed, 95 insertions, 0 deletions
diff --git a/libsecret/Cargo.toml b/libsecret/Cargo.toml
new file mode 100644
index 0000000..93b9a3a
--- /dev/null
+++ b/libsecret/Cargo.toml
@@ -0,0 +1,95 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "libsecret"
+version = "0.6.0"
+authors = [
+    "Bilal Elmoussaoui <bil.elmoussaoui@gmail.com>",
+    "Maximiliano Sandoval <msandova@gnome.org>",
+    "Sophie Herold <sophie@hemio.de>",
+]
+build = false
+exclude = [
+    "gir-files/*",
+    "gir/",
+]
+autobins = false
+autoexamples = false
+autotests = false
+autobenches = false
+description = "Rust bindings of libsecret"
+homepage = "https://world.pages.gitlab.gnome.org/Rust/libsecret-rs"
+documentation = "https://world.pages.gitlab.gnome.org/Rust/libsecret-rs/stable/latest/docs/libsecret"
+readme = "README.md"
+keywords = [
+    "libsecret",
+    "dbus",
+    "secret",
+    "bindings",
+    "freedesktop",
+]
+categories = ["api-bindings"]
+license = "MIT"
+repository = "https://gitlab.gnome.org/World/Rust/libsecret-rs"
+
+[package.metadata.docs.rs]
+all-features = true
+rustc-args = [
+    "--cfg",
+    "docsrs",
+]
+rustdoc-args = [
+    "--cfg",
+    "docsrs",
+]
+
+[lib]
+name = "libsecret"
+path = "src/lib.rs"
+
+[dependencies.ffi]
+version = "0.6"
+package = "libsecret-sys"
+
+[dependencies.gio]
+version = "0.20"
+
+[dependencies.glib]
+version = "0.20"
+
+[dependencies.libc]
+version = "0.2"
+
+[features]
+default = ["v0_18"]
+v0_18 = ["ffi/v0_18"]
+v0_18_6 = [
+    "v0_18",
+    "ffi/v0_18_6",
+]
+v0_19 = [
+    "v0_18_6",
+    "ffi/v0_19",
+]
+v0_20 = [
+    "v0_19",
+    "ffi/v0_20",
+]
+v0_21 = [
+    "v0_20",
+    "ffi/v0_21",
+]
+v0_21_2 = [
+    "v0_21",
+    "ffi/v0_21_2",
+]