summary refs log tree commit diff
path: root/libsecret/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2025-01-30 08:49:22 +0300
committerVika <vika@fireburn.ru>2025-01-30 08:49:22 +0300
commit62263e0e619625f2c5dd0b4364b43bd4fefc8ccd (patch)
treec796d7f78c2205dff77eacb02d43024a254c6d67 /libsecret/Cargo.toml
parent320de85d04061ccc3ce50fb9a460a28068f7146a (diff)
downloadbowl-62263e0e619625f2c5dd0b4364b43bd4fefc8ccd.tar.zst
libsecret: 0.6.0 (private fork) -> 0.7.0 (upstream)
libsecret is now maintained again! No need for a private fork.
Diffstat (limited to 'libsecret/Cargo.toml')
-rw-r--r--libsecret/Cargo.toml95
1 files changed, 0 insertions, 95 deletions
diff --git a/libsecret/Cargo.toml b/libsecret/Cargo.toml
deleted file mode 100644
index 93b9a3a..0000000
--- a/libsecret/Cargo.toml
+++ /dev/null
@@ -1,95 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2021"
-name = "libsecret"
-version = "0.6.0"
-authors = [
-    "Bilal Elmoussaoui <bil.elmoussaoui@gmail.com>",
-    "Maximiliano Sandoval <msandova@gnome.org>",
-    "Sophie Herold <sophie@hemio.de>",
-]
-build = false
-exclude = [
-    "gir-files/*",
-    "gir/",
-]
-autobins = false
-autoexamples = false
-autotests = false
-autobenches = false
-description = "Rust bindings of libsecret"
-homepage = "https://world.pages.gitlab.gnome.org/Rust/libsecret-rs"
-documentation = "https://world.pages.gitlab.gnome.org/Rust/libsecret-rs/stable/latest/docs/libsecret"
-readme = "README.md"
-keywords = [
-    "libsecret",
-    "dbus",
-    "secret",
-    "bindings",
-    "freedesktop",
-]
-categories = ["api-bindings"]
-license = "MIT"
-repository = "https://gitlab.gnome.org/World/Rust/libsecret-rs"
-
-[package.metadata.docs.rs]
-all-features = true
-rustc-args = [
-    "--cfg",
-    "docsrs",
-]
-rustdoc-args = [
-    "--cfg",
-    "docsrs",
-]
-
-[lib]
-name = "libsecret"
-path = "src/lib.rs"
-
-[dependencies.ffi]
-version = "0.6"
-package = "libsecret-sys"
-
-[dependencies.gio]
-version = "0.20"
-
-[dependencies.glib]
-version = "0.20"
-
-[dependencies.libc]
-version = "0.2"
-
-[features]
-default = ["v0_18"]
-v0_18 = ["ffi/v0_18"]
-v0_18_6 = [
-    "v0_18",
-    "ffi/v0_18_6",
-]
-v0_19 = [
-    "v0_18_6",
-    "ffi/v0_19",
-]
-v0_20 = [
-    "v0_19",
-    "ffi/v0_20",
-]
-v0_21 = [
-    "v0_20",
-    "ffi/v0_21",
-]
-v0_21_2 = [
-    "v0_21",
-    "ffi/v0_21_2",
-]