summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2025-01-30 09:51:33 +0300
committerVika <vika@fireburn.ru>2025-01-30 09:51:33 +0300
commit29568a14b389049480591e67a116400d030e8db1 (patch)
tree64048c64f9b24921e35b707bf1b76298480764fe /default.nix
parent62263e0e619625f2c5dd0b4364b43bd4fefc8ccd (diff)
downloadbowl-29568a14b389049480591e67a116400d030e8db1.tar.zst
Provide an application icon
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 1 insertions, 7 deletions
diff --git a/default.nix b/default.nix
index 881b656..de622f9 100644
--- a/default.nix
+++ b/default.nix
@@ -9,7 +9,7 @@
 
 let
   src = let
-    suffixes = [ "meson.options" "meson.build" ".sh" ".po" ".pot" ".in" "LINGUAS" ];
+    suffixes = [ "meson.options" "meson.build" ".sh" ".po" ".pot" ".in" "LINGUAS" ".svg" ];
     suffixFilter = name: type: let
       base = baseNameOf (toString name);
     in type == "directory" || lib.any (ext: lib.hasSuffix ext base) suffixes;
@@ -23,12 +23,6 @@ let
   args = {
     # pname and version are read from Cargo.toml
     inherit src;
-    dummySrc = craneLib.mkDummySrc {
-      inherit src;
-      extraDummyScript = ''
-        cp -r ${./icons.toml} $out/icons.toml
-      '';
-    };
     strictDeps = true;
 
     buildInputs = [