summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-12-16 12:11:52 +0300
committerVika <vika@fireburn.ru>2024-12-16 12:12:01 +0300
commit993a28b59d4bb82a355c1cb38b5ebf7982b25cdc (patch)
tree47c5c0df40f7f91cbcbb57aefeb01e1d551802f7 /Cargo.toml
parentfaa397db358bb5f644e721f3e67250eea202be00 (diff)
downloadbowl-993a28b59d4bb82a355c1cb38b5ebf7982b25cdc.tar.zst
cargo update, bump minimum libadwaita version to 1.6
I wish there was a way to build against newer libadwaita but be able
to gracefully degrade. I heard it's possible in Zig, and `libadwaita`
exposes functions to query the underlying library version at runtime,
so we might be able to get away with it as long as our build-time
environment is new enough...
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d8f0b34..3e7a242 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,7 +10,7 @@ smart-summary = []
 default = ["smart-summary"]
 
 [dependencies]
-adw = { version = "0.7.0", package = "libadwaita", features = ["v1_5"] }
+adw = { version = "0.7.0", package = "libadwaita", features = ["v1_6"] }
 futures = "0.3.30"
 gettext-rs = { version = "=0.7.0", features = ["gettext-system"] }
 gio = { version = "0.20.1", features = ["v2_80"] }