summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-08-20 18:41:40 +0300
committerVika <vika@fireburn.ru>2024-08-20 18:41:40 +0300
commit7e403c00af4956a3996e5570eb0aa578745c520d (patch)
tree8e0b26774c119e47a9adc20f0619dbc450c6ef2f /Cargo.toml
parente6e4de9e15833e4042be5cd71944e9b8929346d4 (diff)
Send posts made in the post composer
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2260672..8d581ff 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,10 +6,19 @@ edition = "2021"
 [dependencies]
 adw = { version = "0.7.0", package = "libadwaita", features = ["v1_5"] }
 futures = "0.3.30"
+gio = { version = "0.20.1", features = ["v2_80"] }
 glib = { version = "0.20.1", features = ["log"] }
 gtk = { version = "0.9.0", package = "gtk4", features = ["gnome_46", "v4_14"] }
+kittybox-indieauth = { git = "https://git.vikanezrimaya.xyz/kittybox", version = "0.2.0" }
+kittybox-util = { git = "https://git.vikanezrimaya.xyz/kittybox", version = "0.2.0" }
+libsecret = { version = "0.5.0", features = ["v0_21_2"] }
 log = { version = "0.4.22", features = ["std"] }
+microformats = "0.9.1"
 relm4 = { version = "0.9.0", features = ["all", "gnome_46", "libpanel"] }
+serde_json = "1.0.125"
+serde_urlencoded = "0.7.1"
+soup3 = "0.7.0"
+thiserror = "1.0.63"
 tokio = { version = "1.39.3", features = ["full", "tracing"] }
 tracing = { version = "0.1.40", features = ["log"] }
 tracker = "0.2.2"