about summary refs log tree commit diff
path: root/meson.build
diff options
context:
space:
mode:
authorWinter <winter@winter.cafe>2022-07-23 21:41:38 -0400
committerWinter <winter@winter.cafe>2022-07-23 23:59:14 -0400
commit1889c11e0dcd995372e6f7876be701ad65b1c64a (patch)
tree347f45dca0e617722a335953571b572baad3795b /meson.build
parent996f669796e83f08fd92506441e0340c0f393f61 (diff)
downloadFurtherance-1889c11e0dcd995372e6f7876be701ad65b1c64a.tar.zst
Switch to gnome.post_install
Diffstat (limited to 'meson.build')
-rwxr-xr-xmeson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index fd87fd4..4957ebc 100755
--- a/meson.build
+++ b/meson.build
@@ -1,10 +1,12 @@
 project('furtherance', 'rust',
           version: '1.5.3',
-    meson_version: '>= 0.50.0',
+    meson_version: '>= 0.59.0',
   default_options: [ 'warning_level=2',
                    ],
 )
 
+gnome = import('gnome')
+
 # Dependencies
 dependency('sqlite3', version: '>= 3.20')
 dependency('dbus-1')
@@ -35,4 +37,8 @@ subdir('data')
 subdir('src')
 subdir('po')
 
-meson.add_install_script('build-aux/meson/postinstall.py')
+gnome.post_install(
+  glib_compile_schemas: true,
+  gtk_update_icon_cache: true,
+  update_desktop_database: true,
+)