about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2025-01-03 14:52:47 +0300
committerVika <vika@fireburn.ru>2025-01-03 15:00:03 +0300
commit4d50adcfb29e7ee3fb66769e82f5beaf65db2532 (patch)
tree85d78d690b346245430703a96443e7703ff48f6e /Cargo.toml
parent8478475d9353aa895c216005cd1b731d8e657d53 (diff)
downloadFurtherance-4d50adcfb29e7ee3fb66769e82f5beaf65db2532.tar.zst
Allow idle time detection on all Wayland desktops HEAD main
Other desktops require C dependencies I don't want to bring in, so
let's leave it at that. Pretty much all of the code was kanged from
the new Iced rewrite.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 94a010b..7f6b0a4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,12 +15,17 @@ directories = "5.0"
 gettext-rs = { version = "0.7", features = ["gettext-system"] }
 gtk4-macros = "0.8.2"
 itertools = "0.10.5"
+lazy_static = "1.5.0"
 log = "0.4"
 num-derive = "0.3.3"
 num-traits = "0.2.15"
 once_cell = "1.17.1"
 rusqlite = { version = "0.28.0", features = ["backup"] }
 serde = { version = "1.0", features = ["derive"] }
+wayland-client = "0.31.7"
+wayland-protocols = { version = "0.32.5", features = ["client", "staging"] }
+wayland-protocols-plasma = { version = "0.3.5", features = ["client"] }
+x11rb = "0.13.1"
 
 [dependencies.gtk]
 package = "gtk4"
@@ -30,4 +35,4 @@ features = ["gnome_46"]
 [dependencies.adw]
 package = "libadwaita"
 version = "0.6.0"
-features = ["v1_5"]
\ No newline at end of file
+features = ["v1_5"]