about summary refs log tree commit diff
path: root/templates-neo/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'templates-neo/Cargo.toml')
-rw-r--r--templates-neo/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/templates-neo/Cargo.toml b/templates-neo/Cargo.toml
new file mode 100644
index 0000000..c0b426c
--- /dev/null
+++ b/templates-neo/Cargo.toml
@@ -0,0 +1,38 @@
+[package]
+name = "kittybox-html"
+version = "0.2.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[build-dependencies]
+libflate = "^2.0.0"
+walkdir = "^2.3.2"
+
+[dev-dependencies]
+faker_rand = "^0.1.1"
+rand = "^0.8.5"
+
+[dependencies]
+ellipse = "^0.2.0"
+http = "^0.2.7"
+html = "^0.5.2"
+serde_json = "^1.0.64"
+include_dir = "^0.7.2"
+axum = "^0.6.18"
+thiserror = "1.0.43"
+[dependencies.url]
+# URL library for Rust, based on the WHATWG URL Standard
+version = "^2.2.1"
+features = ["serde"]
+[dependencies.chrono]
+version = "^0.4.19"
+features = ["serde"]
+[dependencies.kittybox-util]
+version = "0.1.0"
+path = "../util"
+[dependencies.kittybox-indieauth]
+version = "0.1.0"
+path = "../indieauth"
+[dependencies.microformats]
+version="^0.3.0"
\ No newline at end of file