about summary refs log tree commit diff
path: root/smoke-test.nix
diff options
context:
space:
mode:
Diffstat (limited to 'smoke-test.nix')
-rw-r--r--smoke-test.nix54
1 files changed, 0 insertions, 54 deletions
diff --git a/smoke-test.nix b/smoke-test.nix
deleted file mode 100644
index b043a31..0000000
--- a/smoke-test.nix
+++ /dev/null
@@ -1,54 +0,0 @@
-kittybox:
-{ lib, ... }: {
-  name = "nixos-kittybox";
-
-  nodes = {
-    kittybox = { config, pkgs, lib, ... }: {
-      imports = [ kittybox.nixosModules.default ];
-
-      services.postgresql = {
-        enable = true;
-        ensureDatabases = ["kittybox"];
-        ensureUsers = [ {
-          name = "kittybox";
-          ensurePermissions = {
-            "DATABASE kittybox" = "ALL PRIVILEGES";
-          };
-        } ];
-      };
-
-      systemd.services.kittybox.wants = [ "postgresql.service" ];
-      systemd.services.kittybox.after = [ "postgresql.service" ];
-      systemd.services.kittybox.wantedBy = lib.mkForce [];
-
-      services.kittybox = {
-        enable = true;
-        logLevel = "info,kittybox=debug,retainer::cache=warn,h2=warn,rustls=warn";
-      };
-
-      environment.systemPackages = with pkgs; [
-        xh
-      ];
-    };
-  };
-
-  # TODO: Make e2e tests for authentication endpoints and such
-  # Potentially using WebDriver
-  # Could also be implemented with fantoccini
-  testScript = ''
-    kittybox.wait_for_unit("default.target")
-    with subtest("Ensure that Kittybox service is socket activated..."):
-        kittybox.fail("systemctl is-active kittybox.service")
-        kittybox.succeed("systemctl is-active kittybox.socket")
-
-    with subtest("Verify that Kittybox starts correctly..."):
-        kittybox.succeed("xh --no-check-status http://localhost:8080/.kittybox/micropub")
-        kittybox.succeed("systemctl is-active kittybox.service")
-
-    with subtest("Onboarding should correctly work..."):
-        kittybox.copy_from_host("${./onboarding.json}", "/root/onboarding.json")
-        kittybox.succeed("xh --follow http://localhost:8080/.kittybox/onboarding -j @/root/onboarding.json")
-        # Testing for a known string is the easiest way to determine that the onboarding worked
-        kittybox.succeed("xh http://localhost:8080/ | grep 'vestige of the past long gone'")
-'';
-}